All emails rejected due to dovecot_virtual_delivery_no_batch not found

This is the area for a general support questions, discussions and information that you can read and share. Post your experiences, stats and tricks and tips that are not covered elsewhere. Remember, for questions please search the FAQ first, as your question may already be answered.

Moderators: wizard, magicspam

Post Reply
octech
Posts: 2
Joined: Wed Aug 25, 2021 3:37 am

All emails rejected due to dovecot_virtual_delivery_no_batch not found

Post by octech » Wed Aug 25, 2021 4:12 am

For context, I am using magicspam version 2.1-15.2.

Starting today (maybe due to the update to cPanel 98.0.5) all emails to the server are rejected with this message:

Code: Select all

temporarily rejected RCPT <username@domain.tld>: transport "dovecot_virtual_delivery_no_batch" not found in magicspam_virtual_user router     
I had all clients calling because they were unable to send emails to their domains or weren't receiving any emails.

I also have lots of these in the logs (I don't know if unrelated):

Code: Select all

Aug 25 13:08:06 cps magicspam-daemon[31825]: tiny_rex.c:970 ERROR __trex_element(): failed to create character node
Aug 25 13:08:06 cps magicspam-daemon[31825]: tiny_rex.c:1159 ERROR __trex_charnode(): non-printable character -30 found
Aug 25 13:08:06 cps magicspam-daemon[31825]: tiny_rex.c:970 ERROR __trex_element(): failed to create character node
Disabling magicspam globally did not fix it.

I have managed to solve this by commenting out the Magicspam block in the /etc/exim.conf - after commenting that out and restarting exim emails started to come in again.

This leaves the server completely unprotected but better to receive spam than absolutely nothing (ask my clients).

If this doesn't get fixed officially soon I'll remove magicspam and look for an alternative.

magicspam
Posts: 1562
Joined: Tue Oct 28, 2008 2:27 pm

Re: All emails rejected due to dovecot_virtual_delivery_no_batch not found

Post by magicspam » Wed Aug 25, 2021 12:58 pm

Hello octech,

Thank you for contacting us.

Based on the provided information, your Exim configurations appears to have loaded an old MagicSpam router as the 'magicspam_virtual_user' has not existed since version 2.1-9.1 of MagicSpam PRO for cPanel. Assuming that you have the latest MagicSpam PRO for cPanel 2.1-15.2 installed on the server, then there may have been an issue with past MagicSpam upgrades.

To start troubleshooting, would you try reinstalling the the latest MagicSpam PRO for cPanel 2.1-15.2 which can be downloaded from the MagicSpam Download Site. Once you have transferred the installation package onto the cPanel server, uninstall MagicSpam PRO for cPanel by running the following command as root.

Code: Select all

rpm -ev magicspampro-cpanel
Before installing the installation package, please ensure that there are no more MagicSpam configurations in the Exim configuration file (/etc/exim.conf) as your previous edits may cause them to not be removed. If you haven't made any custom Exim configurations, you may want to reset your Exim configuration file to the default version via:

Code: Select all

WHM Interface >> Service Configuration >> Exim Configuration Manager >> Reset
Reset type: Reset the entire Exim configuration to the default settings provided with cPanel & WHM
Next proceed with the installation of MagicSpam PRO for cPanel 2.1-15.2 by running the following command:

Code: Select all

rpm -i /path/to/package
After the installation is complete, monitor the Exim logs any further errors and let us know whether the issue have been resolved.
-- MagicSpam Support Team --

octech
Posts: 2
Joined: Wed Aug 25, 2021 3:37 am

Re: All emails rejected due to dovecot_virtual_delivery_no_batch not found

Post by octech » Thu Aug 26, 2021 3:08 pm

Hello Magicspam, thank you very much for replying.

I tried first without resetting the exim configuration, but ended up being wrong. Then I tried resetting the exim configuration as indicated and then it worked.

Now everything seems to be working correctly, thank you very much for that.

I am pretty confused that this can happen, tbh. Is ther a way to avoid that in the future?

Thank you, best regards.

magicspam
Posts: 1562
Joined: Tue Oct 28, 2008 2:27 pm

Re: All emails rejected due to dovecot_virtual_delivery_no_batch not found

Post by magicspam » Fri Aug 27, 2021 9:26 am

Hey octech,

Glad to hear that the issue has been resolved.

It's hard for us to make any suggestions on a way to avoid the same issue in the future without more information as we haven't see this issue before, but the most likely cause of the issue would have been the upgrade process. Would you be able to provide us with more information on your MagicSpam upgrades.
  1. How long has MagicSpam been installed on the server?
  2. How many MagicSpam upgrades have been performed?
  3. What MagicSpam versions did you upgrade from and to?
  4. Did you perform the upgrades via the command line or interface?
Thanks.
-- MagicSpam Support Team --

Post Reply

Return to “General Discussions and Support Questions”

Who is online

Users browsing this forum: No registered users and 1 guest