Icone do Aplicativo não é exibido no Cpanel

Welcome to MagicSpam Pro for cPanel WHM! A better spam protection in an easy to use cPanel WHM Module. Visit here for support, frequently asked questions, wishlists and discussion groups on this great module to make life with cPanel WHM that much simpler.

Moderators: wizard, magicspam

Post Reply
lucasdomonte
Posts: 9
Joined: Fri Jun 21, 2019 7:08 am

Icone do Aplicativo não é exibido no Cpanel

Post by lucasdomonte » Mon Jul 01, 2019 7:15 pm

Application Icon is not added to the Cpanel in some specific accounts, and the strange thing is that in other accounts with the same Package and even Freature List, it displays the icon normally as you can see in the attached prints.
Screenshot_1.png
Screenshot_1.png (79.61 KiB) Viewed 178 times
Screenshot_2.png
Screenshot_2.png (103.21 KiB) Viewed 178 times

magicspam
Posts: 1224
Joined: Tue Oct 28, 2008 2:27 pm

Re: Icone do Aplicativo não é exibido no Cpanel

Post by magicspam » Tue Jul 02, 2019 2:15 pm

Hello Lucas,

Thank you for your post.

If MagicSpam icon is not presented for all customers that are using same package with MagicSpam protection, simply go to the "Packages" tab in your MagicSpam admin-interface panel and sync the package in question.

Please let us know if this resolves the issue or if you need any further assistance.
-- MagicSpam Support Team --

izghitu2
Posts: 2
Joined: Tue Sep 10, 2019 12:27 am

Re: Icone do Aplicativo não é exibido no Cpanel

Post by izghitu2 » Tue Sep 10, 2019 12:30 am

Hi,

I have the same problem as described by Lucas.

When I wanted to try to fix it as you suggested and go to Plugins -> MagicSpam -> Packages then I do not see any packages listed in there. If I try to create one package then I get a 403 error:
API returned HTTP CODE 403. Is the API installed?

Also I can see a ! sign at the Packages tab in MagicSpam.

I tried reinstalling MagicSpam but it did not help. I also ran cagefs --force-update without any success.

Please help.

Thanks

magicspam
Posts: 1224
Joined: Tue Oct 28, 2008 2:27 pm

Re: Icone do Aplicativo não é exibido no Cpanel

Post by magicspam » Tue Sep 10, 2019 2:34 pm

Hello izghitu2,

Thank you for your post.

We suspect that this issue might be related to the bad value in MagicSpam API Token [/etc/magicspam/.authtoken] or more likely incorrect permissions. In order to resolve this issue, could you please try the following:

Go to the "Manage API Tokens" page in the WHM/cPanel interface and generate a new token.

Once you have generated the new token, please copy and paste the token into:

/etc/magicspam/.authtoken

Also please make sure that the permissions on the .authtoken are as in example below:

-rw-r--r--. 1 magicspam magicspam 32 May 2 15:45 .authtoken

Please let us know if this resolves the issue or if you need any further assistance.
-- MagicSpam Support Team --

izghitu2
Posts: 2
Joined: Tue Sep 10, 2019 12:27 am

Re: Icone do Aplicativo não é exibido no Cpanel

Post by izghitu2 » Wed Sep 11, 2019 7:14 am

Hi,

Thanks. That fixed it.

magicspam
Posts: 1224
Joined: Tue Oct 28, 2008 2:27 pm

Re: Icone do Aplicativo não é exibido no Cpanel

Post by magicspam » Wed Sep 11, 2019 12:13 pm

hello izghitu2,

Thank you for letting us know; we are happy to hear that the issue has been resolved.
-- MagicSpam Support Team --

Post Reply

Return to “MagicSpam Pro for WHM/cPanel”

Who is online

Users browsing this forum: No registered users and 1 guest