After update to cPanel/WHM 11.40 I get a HTTP error 401

This is where the frequently asked questions, and responses is kept. You should do a quick search on any questions before posting to the general forum. Your question may already be answered.

Moderators: wizard, magicspam

Post Reply
magicspam
Posts: 1100
Joined: Tue Oct 28, 2008 2:27 pm

After update to cPanel/WHM 11.40 I get a HTTP error 401

Post by magicspam » Thu Nov 14, 2013 10:55 am

The full error message seen is:
HTTP error 401

cgi/addon_magicspam.cgi

WHM is configured to disallow execution of unregistered applications when logged in as root or a reseller with the "all" ACL. To enable this functionality you must do one of the following: Register this addon using /usr/local/cpanel/bin/register_appconfig (http://docs.cpanel.net/twiki/bin/vie...tKit/AppConfig), Enable the "Allow apps that have not registered with AppConfig to be run when logged in as root or a reseller with the "all" ACL in WHM" option in "Tweak Settings", or add permit_unregistered_apps_as_root=1 to /var/cpanel/cpanel.config, and run /usr/local/cpanel/etc/init/startcpsrvd
This is due to the new security ACLs shipped with this version of cPanel / WHM. To resolve you can either download an updated version of MagicSpam from http://download.magicspam.com , or you can do the following:

* Log in to your cPanel/WHM server command line as "root"

* Run the following commands:

Code: Select all

mkdir -p /var/cpanel/apps
chmod 755 /var/cpanel/apps
echo "service=whostmgr" > /tmp/magicspam.conf
echo "url=/cgi/addon_magicspam.cgi" >> /tmp/magicspam.conf
echo "acls=root" >> /tmp/magicspam.conf
/usr/local/cpanel/bin/register_appconfig /tmp/magicspam.conf
rm -f /tmp/magicspam.conf

Post Reply

Return to “Frequently Asked Questions (FAQ)”

Who is online

Users browsing this forum: No registered users and 1 guest