require_full_addr issue

This is the area for a general support questions, discussions and information that you can read and share. Post your experiences, stats and tricks and tips that are not covered elsewhere. Remember, for questions please search the FAQ first, as your question may already be answered.

Moderators: wizard, magicspam

Post Reply
andi
Posts: 41
Joined: Wed Nov 17, 2010 4:44 am

require_full_addr issue

Post by andi » Wed Jan 12, 2011 6:13 am

hello,
there is ME prof 5.03 and magicSpam v.1.0.5-2 installed on this node. magicSpam check 'require_full_addr' is enabled.

now, there ist domain-account <domain>, with activated 'catch all' option in plesk 9.5.3: all non-existent mails should be forwarded to 'info'-mailbox. but:

# telnet <mailserver> 25
Trying xxx.xxx.xxx.xxx...
Connected to <mailserver>.
Escape character is '^]'.
220 <mailserver> ESMTP MailEnable Service, Version: 0-5.03- ready at 01/12/11 14:08:22
ehlo <maildomain>
250-<mailserver> [xxx.xxx.xxxx.xxx], this server offers 4 extensions
250-AUTH LOGIN
250-SIZE 10240000
250-HELP
250 AUTH=LOGIN
mail from: <sender>
250 Requested mail action okay, completed
rcpt to: nonExistentUser@<domain>
550 Incomplete address for recipient.Rejected by MagicSpam 1.0.5-2 (http://www.magicspam.com/).Visit http://www.linuxmagic.com/best_practice ... _addr.html for more information

furthermore, in magicSpam's 'logtail' i see, that receipient's field for according log line is empty.


thank you for investigation,
andi


p.s.
http://www.linuxmagic.com/best_practice ... _addr.html
should be
http://www.linuxmagic.com/best_practice ... dress.html

magicspam
Posts: 1040
Joined: Tue Oct 28, 2008 2:27 pm

Re: require_full_addr issue

Post by magicspam » Wed Jan 12, 2011 10:46 am

Thanks for the report Andi,

We will let our developers know to update the URL links for sure.

Now.. as to the rule triggering on forwards to catch-alls... that is a bit of a trickier issue (and please note we generally discourage the use of catch-alls - this defeats the entire point of valid recipient checking that e-mail server systems now provide). We've been reviewing this action with full debug and have determined what is causing the issue - there is an apparent re-ordering of expected data for cases of catch-all forwarding rules and the interaction with MagicSpam. This has been forwarded to our development team who expects to be able to resolve this in short order.

Thank you for reporting this Andi.

jeromeh
Posts: 1
Joined: Sun Feb 06, 2011 4:00 pm

Re: require_full_addr issue

Post by jeromeh » Sun Feb 06, 2011 4:03 pm

I too am having this issue and wanted to know how far away a fix is? Also, and more importantly, there is nothing in any of the logs to indicate that the email is being rejected! The only way I found out was an very unhappy customer calling us and reporting the issue!

magicspam
Posts: 1040
Joined: Tue Oct 28, 2008 2:27 pm

Re: require_full_addr issue

Post by magicspam » Mon Feb 07, 2011 1:37 pm

Hello Jeremeh,

We expect to be releasing updated packages within the week of 2011-02-14 - 2011-02-18. As to your statement of no logs indicating the mail was being rejected.. can you please confirm - you checked the MagicSpam logs (using either search or view last xxx entries) and there was no logged event for require_full_addr ?

andi
Posts: 41
Joined: Wed Nov 17, 2010 4:44 am

Re: require_full_addr issue

Post by andi » Tue Feb 22, 2011 1:56 am

am i right, that 'plesk catch-all'-issue has been resolved in magicSpam 1.0.5-3?

regards,
andi

magicspam
Posts: 1040
Joined: Tue Oct 28, 2008 2:27 pm

Re: require_full_addr issue

Post by magicspam » Tue Feb 22, 2011 9:39 am

You are correct - that particular issue is resolved in version 1.0.5-3

Post Reply

Return to “General Discussions and Support Questions”

Who is online

Users browsing this forum: No registered users and 1 guest