Magic Spam Upgrade Failure broke Extension Zone Page

This is the area for a general support questions, discussions and information that you can read and share. Post your experiences, stats and tricks and tips that are not covered elsewhere. Remember, for questions please search the FAQ first, as your question may already be answered.

Moderators: wizard, magicspam

Post Reply
marco_r
Posts: 10
Joined: Tue Dec 01, 2015 1:42 pm

Magic Spam Upgrade Failure broke Extension Zone Page

Post by marco_r » Tue Dec 29, 2015 9:36 am

Hello @Magic Spam - Support,

trying to upgrade Magic Spam to release 2.0.2-1 into Extension Catalog Page (clicking "upgrade" button) we met an error and extension page disappeared completely into our Panel Parallels Plesk - 12.0.18 - CentOS 6.6) and shown this error warning "Internal error: command /usr/local/psa/admin/sbin/modules/magicspam/license_manager is not executable

Message command /usr/local/psa/admin/sbin/modules/magicspam/license_manager is not executable
File lib.cmdwrapper.php
Line 65
Type Exception
Go To Previous Page

Search for related Knowledge Base articles

Can you help us ? ... to retrieve back the correct page : we cannot manage anything as addons now because page not available (internal error) : cannot manage anything about ...

I hold, Regards

Marco_R
System Administrator
Network Integrated ITSol

magicspam
Posts: 966
Joined: Tue Oct 28, 2008 2:27 pm

Re: Magic Spam Upgrade Failure broke Extension Zone Page

Post by magicspam » Tue Dec 29, 2015 10:11 am

Hello Marco,

Thank you for your post and we apologize for the inconvenience.

Could you please try removing the MagicSpam extension and installing it
again from the Plesk Extensions Catalog to see if that resolves the
issue. Note that all your MagicSpam settings will be retained.

Please let us know if you have any further questions.
-- MagicSpam Support Team --

marco_r
Posts: 10
Joined: Tue Dec 01, 2015 1:42 pm

Re: Magic Spam Upgrade Failure broke Extension Zone Page

Post by marco_r » Tue Dec 29, 2015 2:08 pm

Hello @Support Team,

Replied via_email from : [redacted].

Magic Spam completely unistalled but the only one
version available in the "Extension Catalogue" into
our Parallels Plesk Panel 12.0.18 is Magic Spam Release
2.0.2 ... what can i do ? ... recently when i have tried
to upgrade from previous version (attached screenshot)
i got a very bad issue into the page and i had to call
Plesk payed technical support to retrieve back "extension
zone" available into the "server management" panel.

"ms-screenshot.jpg" MagicSpam installed before
our technical issue.

"2015-12-29_21-32.jpg" a recent screenshot by
Parallels Plesk 12.0.18 EXTENSION CATALOG
where i may find icon and "install button" for
MagicSpam Embedded Protection 2.0.2 ...

Originally i run Magic Spam version here attached
into "ms-screenshot.jpg" but i have a problem with
my licence because marked as unknown but i bought
it via_ODIN-OFFICIAL-PORTAL and my licence key :
MSPLSK-2228CB-KBLRFT-968-QTHR9C-2E6HMQ
for MAGIC SPAM STANDARD still running and available.

I hold x your technical support and i hope to not get
this installation error again, cannot break this plesk
page again .... Thanks,

Regards,

Marco
Last edited by magicspam on Tue Dec 29, 2015 2:30 pm, edited 1 time in total.
Reason: Removed email address for privacy reasons

marco_r
Posts: 10
Joined: Tue Dec 01, 2015 1:42 pm

Re: Magic Spam Upgrade Failure broke Extension Zone Page

Post by marco_r » Thu Dec 31, 2015 5:35 am

Hello @Support,

Completely solved : Regards,

ThankU

magicspam
Posts: 966
Joined: Tue Oct 28, 2008 2:27 pm

Re: Magic Spam Upgrade Failure broke Extension Zone Page

Post by magicspam » Thu Dec 31, 2015 11:03 am

Hello Marco,

We are happy to hear your MagicSpam is now back up and running!

Please let us know if you have any other questions.
-- MagicSpam Support Team --

ronin
Posts: 2
Joined: Tue Oct 24, 2017 8:00 am

Re: Magic Spam Upgrade Failure broke Extension Zone Page

Post by ronin » Tue Oct 24, 2017 8:22 am

I seem to be having this same issue. After years of working perfectly, MagicSpam (2.0.12-1) suddenly is displaying an error when I try to access it in Plesk (12.5x):

ERROR: Exception
command /usr/local/psa/admin/sbin/modules/magicspam/license_manager is not executable

We have tried removing and reinstalling, but the problem persists. This was working perfectly as recently as a couple weeks ago.

OS ‪Red Hat Enterprise Linux Server 5.11 (Tikanga)‬
Plesk version 12.5.30 Update #71, last updated at Oct 9, 2017 04:05 AM
The system is up-to-date; last checked at Oct 22, 2017 04:06 AM

magicspam
Posts: 966
Joined: Tue Oct 28, 2008 2:27 pm

Re: Magic Spam Upgrade Failure broke Extension Zone Page

Post by magicspam » Tue Oct 24, 2017 12:35 pm

Hello Ronin,

Thank you for your post.

From the information provided we see that your server is running on:

* ‪Red Hat Enterprise Linux Server 5.11 (Tikanga)‬

Please note that the latest MagicSpam for Plesk does not support this version of Red Hat OS.

MagicSpam packages for ‪Red Hat Enterprise Linux Server 5.11 are only available for Plesk versions 9-11.

We recommend updating to at least RHEL 6 and try installing MagicSpam again. In the meantime, we have also escalated to investigate your unique situation and we will follow up with you on this issue by the end of the week.

We hope that this information helps.
-- MagicSpam Support Team --

ronin
Posts: 2
Joined: Tue Oct 24, 2017 8:00 am

Re: Magic Spam Upgrade Failure broke Extension Zone Page

Post by ronin » Thu Oct 26, 2017 8:14 am

MagicSpam packages for ‪Red Hat Enterprise Linux Server 5.11 are only available for Plesk versions 9-11
MagicSpam has been working flawlessly up to this point on my server, as configured, running Plesk 12.x since it's initial upgrade over two years ago!

magicspam
Posts: 966
Joined: Tue Oct 28, 2008 2:27 pm

Re: Magic Spam Upgrade Failure broke Extension Zone Page

Post by magicspam » Tue Oct 31, 2017 4:55 pm

Hello ronin,

As the latest version of MaigicSpam does not support ‪Red Hat Enterprise Linux Server 5, we would recommend you to upgrade your Operating System to ‪Red Hat Enterprise Linux version 6 or newer.

Alternatively , please email us at:

support@magicspam.com

and we will provide you with the package of the previous version of MagicSpam that supports RHEL version 5.

Please note that if you install older version of MagicSpam in your system, you should turn the automatic updates for MagicSpam in your Plesk off, in order to prevent MagicSpam from updating to the latest version automatically.

We hope this information helps.
-- MagicSpam Support Team --

Post Reply

Return to “General Discussions and Support Questions”

Who is online

Users browsing this forum: No registered users and 7 guests

cron