Stats page issue running on V. 2.0.2-1

This is the area for a general support questions, discussions and information that you can read and share. Post your experiences, stats and tricks and tips that are not covered elsewhere. Remember, for questions please search the FAQ first, as your question may already be answered.

Moderators: wizard, magicspam

Post Reply
marco_r
Posts: 10
Joined: Tue Dec 01, 2015 1:42 pm

Stats page issue running on V. 2.0.2-1

Post by marco_r » Tue Dec 01, 2015 1:52 pm

Hello @Support,

I run Magic Spam V. 2.0.2-1 on Plesk 12.0.8 on a CentOS 6.6 server and i cannot see
statistics page (stats page don't load). It looks like the daily statistics are showing a large
amount to process, which is contributing to the slowness. This doesn't look like it's an
accurate count of emails though, so it may be an issue with the plugin. I would suggest
to look into it to make sure it's not trying to calculate everything into today. Currently,
it says the highest domain to send email to day sent out 777000 emails, which doesn't
match the total number of email receipt and sends today. Can you help us to solve this ?

Thanks for your patronage,

Kindest Regards

Marco_R
FreeLance Network Administrator

magicspam
Posts: 966
Joined: Tue Oct 28, 2008 2:27 pm

Re: Stats page issue running on V. 2.0.2-1

Post by magicspam » Tue Dec 01, 2015 3:59 pm

Hello Marco_r!

We are curious if you may be encountering an issue similar to that found in the following forum thread post:

http://forums.magicspam.com/viewtopic.php?f=15&t=225911

Peterz encountered something similar and the steps for troubleshooting this should be similar for what you are reporting.

Please post back if this thread helps to resolve the issue or if additional trouble shooting is required.

Thanks!

-- MagicSpam Support Team --

marco_r
Posts: 10
Joined: Tue Dec 01, 2015 1:42 pm

Re: Stats page issue running on V. 2.0.2-1

Post by marco_r » Wed Dec 02, 2015 11:52 am

Hello @Support,

The forum post mentions MagicSpam 2.0.1, so it could be there were some changes
to the working of MagicSpam between that version and ours.

==========================================================================

What our technicians here says :

Since we're neither the developers for Plesk, or MagicSpam, we can't really comment
on what might be different.

As for if it's dangerous, we'd only know if it would break things by trying.
Typically we do not suggest installing software manually if Plesk is already
offering it in the repository. Your license is through Plesk, so a manual
installation may not work or could break the billing.

==========================================================================

How can you help me to solve this ? ... we're thinking to manually update to magic Spam
Release 2.1-2 but our technicians says this is not officially supported into server catalog
for extensions in Plesk 12.0.18 so this may break the interface. We are not sure this
will solve current issue too. What can you tell ? ... I hold,

Thanks x your support, Regards

Marco_R
FreeLance Network Administrator

Thanks, Regards

magicspam
Posts: 966
Joined: Tue Oct 28, 2008 2:27 pm

Re: Stats page issue running on V. 2.0.2-1

Post by magicspam » Wed Dec 02, 2015 1:10 pm

Hello Marco_R,

Thank you for the update.

The troubleshooting instructions mentioned in the other forum post for MagicSpam version 2.0.0-1 should still apply to your current version.

As a first step, we would like to see the number of MagicSpam log files in use and their sizes.
Could you please run the following command and provide us the output:

Code: Select all

ls -lah /var/log/magicspam
You mentioned an uncertainty of upgrading to MagicSpam Release 2.1-2.
This should not be a problem.
Please visit the Plesk Extensions Catalog, find MagicSpam in the list and click "Upgrade".

-- MagicSpam Support Team --

marco_r
Posts: 10
Joined: Tue Dec 01, 2015 1:42 pm

Re: Stats page issue running on V. 2.0.2-1

Post by marco_r » Thu Dec 03, 2015 5:29 am

Hello @Support Team,

Here is the output of the command requested.

[root@my ~]# ls -lah /var/log/magicspam
total 380M
drwxr-xr-x 2 magicspam magicspam 4.0K Dec 3 00:00 .
drwxr-xr-x. 23 root root 4.0K Dec 3 03:43 ..
-rw-r--r-- 1 magicspam magicspam 749 May 31 2015 .counter2.dat.05
-rw-r--r-- 1 magicspam magicspam 749 Jun 30 23:59 .counter2.dat.06
-rw-r--r-- 1 magicspam magicspam 749 Jul 31 23:59 .counter2.dat.07
-rw-r--r-- 1 magicspam magicspam 749 Aug 31 23:59 .counter2.dat.08
-rw-r--r-- 1 magicspam magicspam 749 Sep 30 23:59 .counter2.dat.09
-rw-r--r-- 1 magicspam magicspam 749 Oct 31 23:59 .counter2.dat.10
-rw-r--r-- 1 magicspam magicspam 749 Nov 30 23:59 .counter2.dat.11
-rw-r--r-- 1 magicspam magicspam 749 Dec 3 06:06 .counter2.dat.12
-rw-r--r-- 1 magicspam root 437K Dec 3 06:06 mslog
-rw-r--r-- 1 magicspam root 1.5M Dec 2 23:59 mslog.1
-rw-r--r-- 1 magicspam magicspam 375M Dec 1 23:59 mslog.2
-rw-r--r-- 1 magicspam magicspam 576K Jun 15 23:59 mslog.3
-rw-r--r-- 1 magicspam magicspam 338K Jun 14 23:59 mslog.4
-rw-r--r-- 1 magicspam magicspam 454K Jun 13 23:59 mslog.5
-rw-r--r-- 1 magicspam magicspam 742K Jun 12 23:59 mslog.6
-rw-r--r-- 1 magicspam magicspam 813K Jun 11 23:59 mslog.7
[root@my ~]#
--

I hold, thanks x your support : Regards,

Marco_R
FreeLance Network Administrator

magicspam
Posts: 966
Joined: Tue Oct 28, 2008 2:27 pm

Re: Stats page issue running on V. 2.0.2-1

Post by magicspam » Thu Dec 03, 2015 1:24 pm

Hello Marco_R,

Thank you for the output.

The logs appear to be working and look normal at first glance.

It's possible that one of the logs have become corrupt and is causing the problem with the statistics page display.

Could you try the following steps to move the old logs over to a temporary backup directory:

1. Stop MagicSpam by clicking the "Disable Protection" button found under the "Settings" tab in the "System" section.

2. Issue these commands to create a temporary backup directory and move the logs and counter data to it:

Code: Select all

mkdir ~/magicspam-log-backup
 
mv /var/log/magicspam/.counter* ~/magicspam-log-backup

mv /var/log/magicspam/mslog* ~/magicspam-log-backup
3. Start MagicSpam again by clicking the "Enable Protection" button found under the "Settings" tab in the "System" section.

Please let us know if that resolves your issue or if you have any further questions.
-- MagicSpam Support Team --

marco_r
Posts: 10
Joined: Tue Dec 01, 2015 1:42 pm

Re: Stats page issue running on V. 2.0.2-1

Post by marco_r » Fri Dec 04, 2015 2:27 pm

Hello @Support Team,

Yes, stats running without issues now.

Thinking to manually upgrade soon to MagicSpam Release 2.1-2;
you wrote in current ticket this should not be a problem.

We run Plesk 12.0.18 on a CentOS 6.6 Server.

You wrote to visit the Plesk Extensions Catalog, find MagicSpam in
the list and click "Upgrade".

Can you confirm this please ? (so we'll proceed about).

I hold, Thanks

Kindest Regards,

Marco_R
FreeLance Network Administrator

magicspam
Posts: 966
Joined: Tue Oct 28, 2008 2:27 pm

Re: Stats page issue running on V. 2.0.2-1

Post by magicspam » Fri Dec 04, 2015 4:47 pm

Hello Marco_R,

Thank you for the update.

We are happy to hear your stats are back up and running!

The upgrade procedure you outlined in your post should be fine.

Please let us know if you have any further questions.
-- MagicSpam Support Team --

marco_r
Posts: 10
Joined: Tue Dec 01, 2015 1:42 pm

Re: Stats page issue running on V. 2.0.2-1

Post by marco_r » Wed Dec 09, 2015 1:11 am

Hello @Team,

When i will upgrade to MagicSpam - Release 2.1-2
i will find all mine original settings running with no
change as well in the Control Panel ? ...

Thanks x your feedback, Regards

Mark_R
FreeLance Network Administrator

magicspam
Posts: 966
Joined: Tue Oct 28, 2008 2:27 pm

Re: Stats page issue running on V. 2.0.2-1

Post by magicspam » Wed Dec 09, 2015 1:09 pm

Hello Marco_R,

Yes, all your MagicSpam settings will be retained.

Please let us know if you have any further questions.
-- MagicSpam Support Team --

Post Reply

Return to “General Discussions and Support Questions”

Who is online

Users browsing this forum: No registered users and 3 guests

cron