Client Cannot make Status ON?

This is the area for a general support questions, discussions and information that you can read and share. Post your experiences, stats and tricks and tips that are not covered elsewhere. Remember, for questions please search the FAQ first, as your question may already be answered.

Moderators: wizard, magicspam

Post Reply
yabdab
Posts: 6
Joined: Thu Sep 17, 2015 1:50 pm

Client Cannot make Status ON?

Post by yabdab » Thu Sep 17, 2015 1:52 pm

My client logs into his Plesk panel and tries to enable the Status of his email domain. Marks it to green(on) and hits save.
Page reloads and the button is still off(red). The setting is not sticking.

What is the problem?

magicspam
Posts: 1069
Joined: Tue Oct 28, 2008 2:27 pm

Re: Client Cannot make Status ON?

Post by magicspam » Thu Sep 17, 2015 3:02 pm

Hello yabdab,

Thank you for your post.

This is a MagicSpam PRO bug that you and another one of our customer have reported today. Our development team is currently working to fix this problem and we are hoping to get an update out as soon as possible.

We will keep you posted here and via email if we have a new update released. Keep an eye out for any updates on the forum or on twitter @magicspam.

Thank you for your contribution!

-- MagicSpam Support Team --

yabdab
Posts: 6
Joined: Thu Sep 17, 2015 1:50 pm

Re: Client Cannot make Status ON?

Post by yabdab » Fri Sep 18, 2015 6:33 am

If it helps, I am using CloudLinux 6 and the latest update.
12.0.18 Update #65, last updated at Sept 17, 2015 03:30 AM

yabdab
Posts: 6
Joined: Thu Sep 17, 2015 1:50 pm

Re: Client Cannot make Status ON?

Post by yabdab » Fri Sep 18, 2015 6:36 am

Also, if you view the client's dashboard within the panel, then return to the global panel, it still shows the client's panel instead.
The Global admin panel is not being shown.

magicspam
Posts: 1069
Joined: Tue Oct 28, 2008 2:27 pm

Re: Client Cannot make Status ON?

Post by magicspam » Fri Sep 18, 2015 10:07 am

Hello yabdab,

Thank you for the information. It will certainly help us get to the root cause of the status issue. In the meantime, we would like to confirm that the bug you see is the same one we suspect. Please issue the following command:

Code: Select all

ls -al /var/cache/magicspampro/users
In regards to seeing the global dashboard incorrectly, this is a known Plesk-related bug. This is caused because the system fails to reset the session variable after a specific API call is made. We are working with parallels to resolve the issue. The only way to fix it is to Log-out and Log back in.

Please send us the output of the ls command. If you have any further questions, let us know.

Thank you!

-- MagicSpam Support Team --

yabdab
Posts: 6
Joined: Thu Sep 17, 2015 1:50 pm

Re: Client Cannot make Status ON?

Post by yabdab » Sat Sep 19, 2015 3:23 am

Code: Select all

# ls -al /var/cache/magicspampro/users
total 8.0K
4.0K drwxr-xr-x 2 psaadm    psaadm    4.0K Sep 17 15:41 .
4.0K drwxr-xr-x 4 magicspam magicspam 4.0K Sep 17 15:41 ..

magicspam
Posts: 1069
Joined: Tue Oct 28, 2008 2:27 pm

Re: Client Cannot make Status ON?

Post by magicspam » Mon Sep 21, 2015 12:57 pm

Hello Yabdab,

Thank you very much for sending this on. We are planning on releasing a fix for this tomorrow. After you install the updated package, please feel free to report back and let us know how it goes for you.

Thank you,
-- MagicSpam Support Team --

yabdab
Posts: 6
Joined: Thu Sep 17, 2015 1:50 pm

Re: Client Cannot make Status ON?

Post by yabdab » Fri Sep 25, 2015 3:02 am

I made the updates from the past 2 days and the issue remains.

The user selects "ON" and hits save. Alert says that it saved, but you scroll down and the switch is still toggled to "OFF" Status.

magicspam
Posts: 1069
Joined: Tue Oct 28, 2008 2:27 pm

Re: Client Cannot make Status ON?

Post by magicspam » Fri Sep 25, 2015 9:03 am

Hello yabdab,

Thank you for your reply. Please do a quick double check for us an make sure that your version number is 2.1-3.1. After this, you should be able to resolve the issue by toggling the MagicSpam services off and then on in all applicable Service Plans.

Under the "Service Plan" menu, select the applicable plan and then click on the "Additional Services" tab. From there you can uncheck the MagicSpam service and click "Update & Sync". Once you have done this, be sure to re-enable MagicSpam once again.

Thank you,
-- MagicSpam Support Team --

vorden
Posts: 2
Joined: Sat Jul 16, 2016 3:53 am

Re: Client Cannot make Status ON?

Post by vorden » Sat Jul 16, 2016 3:57 am

Good day

This issue seems to still be occurring, we are running the PRO Licence and we are experiencing exactly the same issue, not on all but some accounts.

Please update this post with the resolution as soon as possible.

Thank You

Post Reply

Return to “General Discussions and Support Questions”

Who is online

Users browsing this forum: No registered users and 1 guest