valid_from_domain : Mail from domain [xxx] is missing A or MX DNS record

This is the area for a general support questions, discussions and information that you can read and share. Post your experiences, stats and tricks and tips that are not covered elsewhere. Remember, for questions please search the FAQ first, as your question may already be answered.

Moderators: wizard, magicspam

Post Reply
acordier
Posts: 6
Joined: Fri May 18, 2018 7:14 am

valid_from_domain : Mail from domain [xxx] is missing A or MX DNS record

Post by acordier » Fri May 18, 2018 7:38 am

Hi,

I have an host (let's say host2.domain.com) with DNS entry of type A which can send mails to our company mail server (let's say domain.com).

When I enable valid_from_domain on MagicSpam from Plesk (version 12.5.30) on domain.com server, I get the following errors in host2 maillog:

Code: Select all

May 16 03:42:35 host2 postfix/smtp[13298]: A8A714853F3: to=<webmaster@domain.com>, relay=mail.domain.com[164.132.xxx.yyy]:25, delay=0.34, delays=0.1/0/0.17/0.06, dsn=5.7.0, status=bounced (host mail.domain.com[164.132.xxx.yy] said: 550 5.7.0 Mail from domain [root@host2.domain.com] is missing A or MX DNS record. See http://spamauditor.org/best-practices/valid_from_address/ for more information. Protection provided by MagicSpam 2.0.16-1 http://www.magicspam.com (in reply to RCPT TO command))
I don't understand why the mail is not passing the filter since there is a A entry for host2.domain.com in our DNS.
As far as I know, only the domain part of root@host2.domain.com is checked right ?

Thanks for any help.

magicspam
Posts: 1050
Joined: Tue Oct 28, 2008 2:27 pm

Re: valid_from_domain : Mail from domain [xxx] is missing A or MX DNS record

Post by magicspam » Fri May 18, 2018 11:17 am

Hello acordier,

Thank you for your post.

In order to better assist you with this issue, could you please send us MagicSpam logs for this email transaction?

To retrieve MagicSpam logs, you can use the MagicSpam interface and access the "Logs" tab.

For more information about the valid HELO domain, please see the following best practices article:

http://spamauditor.org/best-practices/v ... dentifier/

Thank you,
-- MagicSpam Support Team --

acordier
Posts: 6
Joined: Fri May 18, 2018 7:14 am

Re: valid_from_domain : Mail from domain [xxx] is missing A or MX DNS record

Post by acordier » Tue May 22, 2018 2:28 am

Hello,

Thanks for your answer.

Here is the log when sending mail from host2 to

Code: Select all

Tuesday, May 22 2018 @ 10:35:29 AM
SPAM[valid_from_domain]
no
151.80.27.92
host2.domain.com
host2.domain.com
root@host2.domain.com
acordier@domain.com
Please notice that the bounce message is well delivered... :

Code: Select all

Tuesday, May 22 2018 @ 10:35:29 AM
NDR
no
151.80.27.92
host2.domain.com
host2.domain.com
bounce message
webmaster@domain.com
Why do you mention HELO in your answer ? The HELO seems to be Ok (require_helo and resolve_helo_domain are ON).

magicspam
Posts: 1050
Joined: Tue Oct 28, 2008 2:27 pm

Re: valid_from_domain : Mail from domain [xxx] is missing A or MX DNS record

Post by magicspam » Tue May 22, 2018 12:36 pm

Hello acordier,

Thank you for your reply and the additional information.

Please ignore the HELO remark as it is posted in an error, we intended to send you following article instead:

http://spamauditor.org/best-practices/v ... m_address/

We have now passed the provided information to our development team for investigation and will let you know once we gave more information.

Please let us know if you have any questions in the meantime.
-- MagicSpam Support Team --

acordier
Posts: 6
Joined: Fri May 18, 2018 7:14 am

Re: valid_from_domain : Mail from domain [xxx] is missing A or MX DNS record

Post by acordier » Wed May 23, 2018 11:22 pm

Hello,

I have already read the documentation you pointed me to, and found no answer except "So the domain portion of the email address provided will need" and "If both are missing, we should reject the email as we cannot respond properly if there is a problem.".

This leave me doubtful...

magicspam
Posts: 1050
Joined: Tue Oct 28, 2008 2:27 pm

Re: valid_from_domain : Mail from domain [xxx] is missing A or MX DNS record

Post by magicspam » Thu May 24, 2018 1:57 pm

Hello acordier,

Thank you for your post.

To continue troubleshooting this issue, could you please query for an A or MX record for the given domain directly from your server that has MagicSpam installed on:

dig A host2.domain.com
dig MX host2.domain.com

and let us know if it resolves properly?

Also, please perform these queries on all nameservers listed in your /etc/resolv.conf:

e.g: dig A host2.domain.com @<IP Of The DNS Server>

Thank you,
-- MagicSpam Support Team --

acordier
Posts: 6
Joined: Fri May 18, 2018 7:14 am

Re: valid_from_domain : Mail from domain [xxx] is missing A or MX DNS record

Post by acordier » Fri May 25, 2018 12:45 am

As I already said, there is a A record working for host2.domain.com and it is visible from the host hosting MagicSpam.

Result of dig A host2.domain.com :

Code: Select all

; <<>> DiG 9.9.4-RedHat-9.9.4-61.el7 <<>> A host2.domain.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 10607
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;host2.domain.com.            IN      A

;; ANSWER SECTION:
host2.domain.com.     10800   IN      A       151.80.27.92

;; Query time: 17 msec
;; SERVER: 213.186.33.99#53(213.186.33.99)
;; WHEN: ven. mai 25 09:02:48 CEST 2018
;; MSG SIZE  rcvd: 63

There is no MX record for this domain, dig MX host2.domain.com gives :

Code: Select all

; <<>> DiG 9.9.4-RedHat-9.9.4-61.el7 <<>> MX host2.domain.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 39830
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;host2.domain.com.            IN      MX

;; AUTHORITY SECTION:
domain.com.          3542    IN      SOA     a.dns.gandi.net. hostmaster.gandi.net. 1524233131 10800 3600 604800 10800

;; Query time: 34 msec
;; SERVER: 213.186.33.99#53(213.186.33.99)
;; WHEN: ven. mai 25 09:41:02 CEST 2018
;; MSG SIZE  rcvd: 109
By the way, is there any way to be notified by mail when an answer is given here ?

magicspam
Posts: 1050
Joined: Tue Oct 28, 2008 2:27 pm

Re: valid_from_domain : Mail from domain [xxx] is missing A or MX DNS record

Post by magicspam » Fri May 25, 2018 4:51 pm

Hello acordier,

Thank you for providing us the requested information.

This is very unusual issue and we have now passed this information to our development team which is looking into this issue.

For testing purposes, could you please provide us additional information about your system:

- MagicSpam Version

- Operating System and Version

- Operating System Architecture (32 bit or 64 bit)

- Plesk Version

- MTA (Qmail, Postfix)


We currently do not have a notifications for answered posts; however, feel free to contact us via our support email address for faster communication.

Our email address is: support@magicspam.com

and our offices are open Mon-Fri 8:30 AM - 4:30 PM Pacific time.

Thank you for your patience and your assistance in troubleshooting this issue.
-- MagicSpam Support Team --

acordier
Posts: 6
Joined: Fri May 18, 2018 7:14 am

Re: valid_from_domain : Mail from domain [xxx] is missing A or MX DNS record

Post by acordier » Mon May 28, 2018 12:30 am

- MagicSpam Version : 2.0.16-1 Free Edition (license MSPLSK-FREE)

- Operating System and Version : CentOS Linux release 7.5.1804

- Operating System Architecture (32 bit or 64 bit) : 64 bits

- Plesk Version : 12.5.30 (update 76)

- MTA (Qmail, Postfix) : Postfix

magicspam
Posts: 1050
Joined: Tue Oct 28, 2008 2:27 pm

Re: valid_from_domain : Mail from domain [xxx] is missing A or MX DNS record

Post by magicspam » Tue May 29, 2018 11:52 am

Hello acordier,

Thank you for providing us the additional information, however we were unable to replicate this issue.

As this is quite unique issue, we would appreciate if you would be able to grant ssh (root) access to your server for our Senior Engineer Team
to investigate this issue directly.

If you are able to grant us remote SSH access to your server, please contact us at our support email address and we will provide you with the further information.

Our support email address is: support@magicspam.com

Thank you again for your patience an your assistance on this matter.

Please let us know if you have any questions in the meantime.
-- MagicSpam Support Team --

Post Reply

Return to “General Discussions and Support Questions”

Who is online

Users browsing this forum: No registered users and 8 guests